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1 Introduction 
This entire manual is a core manual. It describes the installation and uninstallation of the OMX 
SECUR Back Office Server and Client. 

A new user is recommended to read this Introduction chapter first.  

Overview 
 

This chapter provides information needed before the installation: 
 OMX SECUR Back Office Application 
 Equipment Requirements 
 Installation Overview 
 References 

 

Contents 
 

Information: 
 Components 
 Back Office Client 
 Hardware Requirements for the BO Server 
 Hardware Requirements for the BO Client 
 Software Requirements 
 BO Server Kit 
 BO Client Kit 
 TCP/IP Address Resolution 
 Folder Structure 
 Registry Entries 

 

To top of chapter 1. 

1.1 OMX SECUR Back Office Application 

1.1.1 Components 

The OMX SECUR Back Office Application (BO) includes a set of software components for 
handling the members’ interaction with the OMX SECUR Clearing System and for downloading 
clearing information to the member site. It consists of the following parts: 
• OMX SECUR Back Office Server (BO Server) – a process running in the background 
• OMX SECUR Back Office Watchdog (BO Watchdog) – a process running in the 

background 
• Microsoft Access database (MS Access database) – storing customer-specific data 
• OMX SECUR Back Office Client (BO Client) – graphical user interface 

The BO Server is running in the background all day as a service on Windows operating system. It 
is connected to OMnet and exchanges clearing information which the central OMX SECUR 
Clearing System.  
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The MS Access database is installed on the BO Server node and retrieves customer-specific data 
from the OMX SECUR Clearing System database at login every day. 

It is also possible to use a Microsoft SQL Server database instead of MS Access but then certain 
extra installation steps need to be taken care of according to the OMX SECUR Back Office 
Database guide. 

The BO Watchdog controls start and restart of the BO Server. If the BO Server stops, the BO 
Watchdog restarts it immediately. 

The BO Client displays data stored in the database to the user. It provides dialog boxes for the user 
to enter data to be sent to the SECUR Clearing System. Many BO Clients within the same member 
can use the same BO Server and the same database. 

Figure 1:  Design Overview of the OMX SECUR Back Office Application 

 

1.1.2 Back Office Client 

The purpose of the BO Application is to cover activities needed by clearing member personnel in 
an efficient and user-friendly way. It includes functions such as retrieving information provided by 
the central system and requesting exercises on positions. 

Figure 2:  Back Office Client Main Window 

 

To top of chapter 1. 
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1.2 Equipment Requirements 

1.2.1 Hardware Requirements for the BO Server 
• Intel Pentium II 400 MHz or faster 
• 512 Mb of memory 
• 120 - 500 Mb of disk, depending on the amount of trades and if the BO Server creates 

Interface Files. 
• Page-file size 500 Mb 

1.2.2 Hardware Requirements for the BO Client 
• Intel Pentium II 266 MHz or faster 
• 256 Mb of memory 
• 100 Mb of disk 

1.2.3 Software Requirements 
• Microsoft® Windows 2000™ (Service Pack 4) operating system. BO version 6.5 and 

later can also be used with the Windows XP™ operating system. 

1.3 Installation Overview 

1.3.1 BO Server Kit 

The OMX SECUR Back Office Server (BO Server) will be installed as a service with no automatic 
start. To keep the BO Server alive at all times, a Watchdog will be installed at the same time as the 
Server. The Watchdog will be is installed as a service with automatic startup. 

The BO Server kit program performs the following actions: 
• Creates the directory structure under Program Files 
• Installs the BO Server executable files and DLLs 
• Inserts BO Server configuration data into the Registry 
• Creates an MS Access Database 
• Creates an ODBC system data-source name, DSN pointing to the database 
• Registers the Bo_srv program as a service with no automatic start 
• Registers the Bo_wtchdg program as a service with automatic start 
• Adds an icon in the start menu: Start ⇒ Programs ⇒ OMX ⇒ SECUR. 

1.3.2 BO Client Kit 

The BO kit program performs the following actions: 
• Creates the directory structure under Program Files 
• Installs the BO Client executable files and DLLs 
• Inserts BO Client configuration data into the Registry 
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• Adds two icons in the start menu: Start ⇒ Programs ⇒ OMX ⇒ SECUR ⇒ 
Back Office for <Application Title>. 

1.3.3 TCP/IP Address Resolution 

Make sure that the IP addresses and identifications of the BO Client and Gateway nodes are entered 
into the “hosts” file located on: C:\WINNT\system32\drivers\etc. 

Example:   

195.135.166.241  localhost 

To top of chapter 1. 

1.3.4 Folder Structure 

The installation program creates the following default folder structure for the BO files if not 
customized by the user: 

Program Files:  <ROOT>\BinaryFiles – the names of the BO Client, BO Server and BO 
Watchdog  
reflect the instanses 

Uninstall Files: <ROOT>\BinaryFiles\<instance #> 

Database:  <ROOT>\DataBase\<instance #> 

Reports:   <ROOT>\Reports\<instance #> 

Interface Files: <ROOT>\InterfaceFiles\<instance #> 

Log Files:  <ROOT>\LogFiles – the names of the log files reflect the instanses 

The default root folder <ROOT> is: 

C:\Program Files\OM Technology\SECUR Back Office 

The folder structure above can be entirely customized. 

1.3.5 Registry Entries 

Some registry settings are set up in Windows Registry during the installation. OMX SECUR Back 
Office specific registry settings are stored in: 

HKEY_LOCAL_MACHINE\SOFTWARE\OMX\SECUR\BackOffice\<INSTANCE> 

The parameters in the registry should not be modified. If modifications seem necessary, consult 
OM personnel. 

1.4 Manual Features 

1.4.1 How to Use this Manual 

This manual is intended as a self-tutorial with brief explanations of the fields and functions 
available in the application. Its organization complies with the main menu options and does not 



 19.0-X 2005-12-08 11:13 SECUR™ Back Office Installation Guide Core 
                      

 

© OMX Technology • 2005 11 (38) 

correlate to specific use cases. The manual can be used on-screen or printed. On-screen clickable 
links are provided to speed up browsing and finding information.. 

Table 2:  Manual Structure 

Chapter Section Sub-Section Body 

Each chapter relates to a main menu option and describes activities included. In the beginning of 
the chapter an overview of its sub-menu options is presented. Then a number of clickable links to 
various chapter parts are provided, such as: 

 Procedures 
 Windows and dialogs 
 Right-click menus 
 Field description 
 Tables 
 More fact information 

The main part of the chapter is divided into sections that deal with a specific sub-menu option or a 
specific function. 

 Each section is divided into sub-sections of various types to present information 
relevant to the specific sub-menu option or the specific function. On each page there 
is a link to the chapter top to provide quick access to other parts of the document. 

… Window Description of a window 
Figure 
Tables: Search Filters – how to specify the 

window search area to display desired 
items 

 List Columns – descriptions of all fields 
in the window listed in alphabetical 
order 

 Action Buttons – what happens when the 
button is selected 

… Dialog Description of a dialog 
Figure 
Tables: Input Specifiers – how to specify the 

dialog input fields to create a new item 
 Action Buttons – what happens when the 

button is selected 

… Right-Click 
Menu 

Description of a right-click menu 
Figure 
Table: Menu Options – what happens when an 

item in the list is selected followed by 
selection of a right-click menu option  

Procedure Instruction steps for a certain activity 

 

About … Certain facts are described in detail 
 

To top of chapter 1. 
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1.4.2 Manual Conventions 

Table 3:  lists the conventions used in this manual: 

Table 3:  Manual Conventions 

Convention Description 

First Capital 

 

Indicates application names such as names of menus, windows, 
options, fields and buttons. 

Italic Indicates references to chapters and sections in the manual. 
Computer style Indicates computer text input or output in command line 

windows; file or directory names. 

Label style Indicates software buttons in the application. 

Field style Indicates a field, menu, menu option or window name used by 
the application. 

Value style Indicates values that can be presented by the application in 
dialogs and lists. 

[Key] Indicates hardware keys 

Example:   

[Enter] indicates the enter key on the keyboard. 

<variable> Indicates a document variable that must be replaced with its 
proper value. 

⇒ Indicates a sequence of choices. 

Example:   

“Choose Deal-Trade ⇒ Synthetic Delivery ⇒ Confirm 
button.” 

This sequence is the same as “Choose Deal-Trade on the 
main menu, then choose Synthetic Delivery on the sub-
menu and finally click the Confirm button in the window that 
opened.” 

Contents Clickable link to the Contents list. 

To top of chapter 1. Clickable link to the chapter top. 
 

 How to Use this Manual 
 Manual Conventions 
 Manual Structure 

Clickable links to chapter parts. 

 

1.5 References 
1 OMX SECUR Back Office Database Guide.
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2 Installation 
Note:  Since the Server starts as soon as it is installed, we strongly recommend that these actions 

take place outside trading hours because the download can affect the performance of 
potential trading applications sharing the same physical connection.  

Overview 
 

This chapter describes how to install the components: 
 Preparations 
 Application Installation 

 

Contents 
 

Procedures: 
 Preparing BO Server 
 Preparing BO Client 
 Stopping BO Server and Watchdog 
 Installing  

Information: 
 Installation Options 
 Previous Installation 
 Installation Program 
 BO Server Setup Dialogs 
 BO Client Setup Dialog 
 Program Root Folder Setup Dialog 
 Customized Program Folder Setup 

Dialogs 

Figures: 
 OMX SECUR Splash Screen 
 Folder Dialog 
 Folder Customize Dialog for Server without HTML 

Files 
 Folder Customize Dialog for Server with HTML Files 
 Folder Customize Dialog for Client 

Tables: 
 Installation Program – Action Elements 
 Server Settings 1 Dialog – Field/Button Descriptions 
 Server Settings 2 Dialog – Field Descriptions 
 Server Settings 3 Dialog – Field Descriptions 
 Client Settings Dialog – Field Descriptions 

To top of chapter 2. 

2.1 Preparations 

2.1.1 Installation Options 

Using different application instances means that the installed application is opened with different 
installation settings. Different instances can also be used to keep different application versions on 
the same computer.  

A complete installation procedure must be performed to install a new instance. The instance 
numbers identify these installed instances. The application instance number is included in the 
license key on the fourth position as described in the installation procedure 2.2.6. The different 
installation settings are stored in different folders in the Registry as described in 1.3.5. 

The application executable files are stored in the <root>\ BinaryFiles folder with names reflecting 
their version. All other application files, such as database and reports, are stored in subfolders using 
the instance number. 
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Note:  Although the BO application provides the option to install more than one instance of the 
BO Server and/or Client it is recommended to use only one instance on each computer. The 
instance number is optional, for example 1. 

Upgrading the Application 

To upgrade the application to a new version the old instance number can be used as well as many 
of the old settings as follows: 

1. Instance # – the old # should be used. 

2. OMnet node and Socket – the old node can be used only if it is upgraded to the new 
version. 

3. Client IPC – the old number can be used. 

4. Delete old executable file – Yes. 

5. Socket number – the old number can be used. 

6. Application title – the old title can be used or changed. 

The other settings do not depend on instance or version. 

Installing a New Version of the Application 

To install a new version of the application and keeping the old version a new instance number must 
be used as well as the following settings: 

1. Instance # – a new # must be used. 

2. OMnet node and Socket – a different node must be used upgraded to the new version. 

3. Client IPC – a new number must be used. 

4. Delete old executable file – No. 

5. Socket number – a new number must be used (but the same number as the client IPC for 
the corresponding instance). 

6. Application title – a new title must be used. 

The other settings do not depend on instance or version. 

To top of chapter 2. 

2.1.2 Previous Installation 

If the BO Server and/or Client has been previously installed, the BO Watchdog and all instances of 
the BO Server must be manually stopped from the Control Panel / Services window as described in 
2.1.5. 

Installation of a new version of the BO application will remove the old program files before 
installing the new files. Some of the old installation settings in the Registry will remain though and 
appear in the installation dialogs, where they can be edited. 

It is generally not recommended to uninstall the old version of the BO application first as described 
in section 3.3. In this case all old installation settings in the Registry and the database would be 
deleted. 
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To top of chapter 2. 

2.1.3 Preparing BO Server 

To prepare for BO Server installation, perform the following steps: 

1. Make sure that you have the following information: 
• OMnet gateway host name 
• OMnet gateway socket number 
• OMnet BO user Id, trading code 
• OMnet user password 
• The name of your authentication domain 
• Application License key (required, provided by the exchange) 

Note:  The OMnet BO user id and initial password are supplied by the 
Exchange. 

2. Log in to Windows as Administrator. 

3. If the BO Server has been previously installed, stop the BO Watchdog and all 
instances of the BO Server from the Control Panel / Services window as 
described in 2.1.5. 

Note:  It is essential that the BO Watchdog be stopped before the BO 
Server. 

4. The BO Server installation installs ODBC, standards for database 
communication. For the installation to work properly shut down all active 
programs and all services in the Control Panel. 

2.1.4 Preparing BO Client 

To prepare for BO Client installation, perform the following steps: 

1. Make sure that you have the following information: 
• OMX SECUR BO Server node name 
• OMX SECUR BO Server socket number 
• Application License key (required, provided by the exchange) 

2. Log in as Windows Administrator. 

3. If the BO Client has been previously installed, stop the BO Watchdog and all 
instances of the BO Server from the Control Panel / Services window as 
described in 2.1.5. 

 

To top of chapter 2. 
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2.1.5 Stopping BO Server and Watchdog 

Perform one of the following procedures to stop the BO Server and Watchdog: 

Actions for Windows 2000 

1. Log in as Administrator to the computer running the BO Server. 

2. Select Start ⇒ Settings ⇒ Control Panel ⇒ Administrative 
Tools ⇒ Services. 
Result:  The Services window opens displaying service items. 

3. Select the Back Office Watchdog item ⇒ Stop on the right-click menu. 
Result:  The Watchdog stops. 

4. Select the Back Office Server <instance> item ⇒ Stop on the right-click 
menu. 
Result:  The BO Server <instance> stops. 

5. Close the Services window. 
 
 

To top of chapter 2. 

2.2 Application Installation 

2.2.1 Installation Program 

The OMX SECUR Back Office setup program presents a number of dialog boxes to let the user 
configure the application as desired. Table 4:  describes the actions triggered by the buttons at the 
bottoms of these dialog boxes:  

Table 4:  Installation Program – Action Elements 

 
To continue to next dialog box, click Next. 

 
To change settings in previous dialog boxes, click Back. 

 
To exit the installation before completion, click Exit Setup. No files will be 
installed on your computer. 

 
To get help with the settings, click Help. 
Result:  A help box opens. To get back to the dialog box, just click somewhere on 

the screen. 
 

Windows 
2000 
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Figure 3:  OMX SECUR Splash Screen 

 

2.2.2 BO Server Setup Dialogs 

Table 5:  Server Settings 1 Dialog – Field/Button Descriptions 

Field/Button Description 

OMnet 

OMnet node If you want to add a node, specify a node where an OMnet gateway is 
located. On this node the central Clearing database is located from 
which the BO Server retrieves information to store locally in the BO 
database. The OMnet node must be configured for the same OMex 
version as the version being installed. 

Socket number Enter the socket number of that OMnet gateway. 

Node, Socket Selecting a set of node and socket copies the information to the 
OMnet Node and Socket number fields. 

Add Clicking Add copies the node in the OMnet node field to the 
Node list. 

Remove Clicking Remove will delete the selected node from the Node list. 

Up, Down Will move the selected node up or down in the Node list. 

User Enter the OMnet user identification, also known as trading code. The 
server will be dedicated to the member to whom the trading code 
relates. 

Note:  The OMnet user id and password are defined in PD. 

Note:  To log in to the BO Client, Windows username and password 
will be used. 

Password Enter the OMnet password. 

Confirm Confirm the OMnet password. 

Client IPC 

Socket number for This is the socket number the BO Server uses and corresponds to the 
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client connection socket number for the BO client settings.  

Note:  If several instances are installed on the same machine, each 
instance must use a unique number. Otherwise the client may 
(try to) connect to an unintended server instance. 

 

Table 6:  Server Settings 2 Dialog – Field Descriptions 

Field/Button Description 

Security 

Authentication 
domain 

Any BO user must be registered with an windows domain. This is 
checked every time a user tries to log in.  

Logfiles 

Max no of logfiles 
to keep 

Enter the number of logfiles to keep in the logfiles directory. 

Max no of days to 
keep logfiles 

Enter the number of days to keep the logfiles. The server deletes the 
logfiles that are older than this. 

Create HTML files 

Create HTML files 
automatically 

Check this box if the Server should create HTML indexfiles for 
reports and interface files 

Reports 

Number of days to 
keep reports 

Enter the number of days to keep the reports before they are deleted. 

ISDN 

Connection to 
OMnet via ISDN 

Check this box if the Server connects to OMnet via ISDN.  

 

Table 7:  Server Settings 3 Dialog – Field Descriptions 

Fields/Buttons Description 

Database 

Days to keep 
trades and clearing 
information for 
expired series 

This is the number of calendar days trades and clearing information 
are kept in the B/O database. After this, they are deleted permanently 
from the database. Changing this value affects the size of the 
database. (Positions on the other hand, are kept as long they are kept 
in the central system, but never longer than what this parameter 
specifies. Please refer also to the housekeeping section in the BO 
Database Guide). 

Days to keep 
trading statistics, 
payments and 
margins 

This is the number of trading days this information is kept in the 
SECUR B/O database after the information was first stored. 
Changing this value affects the size of the database. 

Note:  Of the 4 windows related to Margining (Margin 
Requirements, Account Market Margin, Total Account 
Margin and Total Member Margin) only data related to the 
first one (Margin Requirements) is stored locally and thus 
affected by this setting. Other Margin data is stored in the 
central system and hence is dependent on the corresponding 
settings for the central system. Please refer also to the 
housekeeping section in the BO Database Guide). 
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Startup 

Server start time This is the time when the BO Server is starting up in the morning. It 
has to have the format hhmmss, e.g. 093000 for 09:30 

Server stop time This is the time when the BO Server is exiting and restarted in the 
evening. It has to have the format hhmmss, e.g. 233000 for 23:30. 

Interface Files 

Create interface 
files automatically  

By checking this box, the interface files supported by OMX SECUR 
Back Office are created by the Server at start-up and during after 
business. 

Days to keep 
interface files 

This is the number of days the interface files remains on disk before 
they are deleted. 

Download 
preliminary margin 
vector files. 

Specifies whether preliminary vector files should be downloaded or 
not. 

Old Executables 

Delete executable 
files from previous 
version 

By checking this box, the executables from older version are deleted. 
This is the default action. 

Uncheck the option if you want to keep the previous version as a 
different instance. 

 

To top of chapter 2. 

2.2.3 BO Client Setup Dialog 

Table 8:  Client Settings Dialog – Field Descriptions 

Fields Description 

Server Connection 

Server node Enter identification of the node where the BO Server will be running. 
If you are installing the BO Server enter the node identification of 
your own computer. 

Socket number Enter the socket number used by the BO Server. Use the socket 
number correlated to the intended instance of the BO server. If you 
are installing both server and client at the same time, the correct 
number will be automatically suggested as entry.  

Note:  If several instances are installed on the same machine, each 
instance must use a unique number. Otherwise the client may 
(try to) connect to an unintended server instance. 

Application Title 

Text in application 
title 

Enter desired text to appear on the application title bar of the 
windows and on the start icon. Use different application titles for 
different instances. 

Note:  Avoid using the following characters in the title, they are not 
supported by Windows: 
\ ? | > < : / * " 

 

To top of chapter 2. 
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2.2.4 Program Root Folder Setup Dialog 

Use the Browse button to change the automatic <Root> folder value that the setup program will 
use for installing files. 

Figure 4:  Folder Dialog 

 

2.2.5 Customized Program Folder Setup Dialogs 

Use the Customize button to select specific folders for all file groups that the setup program will 
use for installing files: 
• Program files 
• Database (only for Back Office server) 
• Reports 
• Interface files 
• Log files 
• Report and interface files (only for BO Sserver when HTML files are created, because 

in this case these files must be located to the same folder.) 
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One of the figures below appears when the Customize button is chosen in the Folder dialog. 

Figure 5:  Folder Customize Dialog for Server 
without HTML Files 

 

Figure 6:  Folder Customize Dialog for Server 
with HTML Files 

 

Figure 7:  Folder Customize Dialog for Client 

 

 

 

To top of chapter 2. 
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2.2.6 Installing 

Perform the procedure to install the BO Server and/or BO Client: 

1. Double-click the file: 

OMSECUR_BackOffice_v<version#>.exe 

Result:  The OM OMX SECUR Back Office - Welcome dialog opens. 
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2. Read the text ⇒ Next. 
Result:  The OMX SECUR Back Office - Registration dialog opens, used for setup 

choice and for registration. 

 

3. Select the desired installation option, specify user Name, Company and License Key. 

4. ⇒ Next. 
Result:  A Registration Information box appears. 
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5. Check your registration entries are correct ⇒ Yes. 
Result:  The OMX SECUR Back Office - Server Settings 1 dialog opens if the BO 

Server setup was chosen, otherwise go to step 11. 

 

6. Enter the settings for the BO Server connections according to Table 5: ⇒ Add. 

Note:  One set of OMnet node and Socket number is mandatory but more than one 
set can be specified. If the server cannot login to OMnet using the first set, it tries 
to connect using the next set until all sets are tried.  
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7. ⇒ Next. 
Result:  The OMX SECUR Back Office - Server Settings 2 dialog opens only if the 

BO Server setup was chosen. 

 

8. Specify settings for the BO Server: Authentication domain (mandatory), Logfiles, 
Create HTML files, Reports, and ISDN according to Table 6: . 
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9. ⇒ Next. 
Result:  The OMX SECUR Back Office - Server Settings 3 dialog opens only if the 

BO Server setup was chosen. 

 

10. Specify settings for the Database, Startup, Interface files and Old executables 
according to Table 7: . 
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11. ⇒ Next. 
Result:  The OMX SECUR Back Office - Folder dialog opens. 

 

12. Check the Dual Positions checkbox if the exchange is intended to keep positions for 
current clearing date and next clearing date. 

13. Select installation folders in one of the following ways: 

a) To accept the default <root> for the setup program to install all OMX SECUR 
Back Office files goto next step. 

b) To specify a specific <root> ⇒ Browse as described in 2.2.4 ⇒ OK. 

c) To specify specific folders for program groups ⇒ Customize as described in 
2.2.5 ⇒ OK. 
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14. ⇒ Next. 
Result:  The OMX SECUR Back Office - Client Settings dialog opens only if the 

BO Client setup was chosen. 
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15. Enter the settings according to Table 8:  ⇒ Next. 
Result:  The OMX SECUR Back Office - Ready to Install dialog opens. 

 

16. Check that all recorded settings are correct ⇒ Start Install. 
Result:  An Information box may appear, providing a choice to keep or delete the 

database from a previous installation. 

17. If you are upgrading an existing installation, it is recommended to keep the database by 
clicking Yes. 
Result:  The installation of OMX SECUR Back Office starts. The progess is shown. 
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18. Wait until the OMX SECUR Back Office - Setup Complete dialog appears. 
Result:  The installation is completed. 

 

19. Choose Yes, I want to restart my computer now ⇒ Finish. 
Result:  The computer is restarted. 

 

To top of chapter 2. 
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3 After Installation 

Overview 
 

This chapter describes actions to be taken after the installation: 
 BO Server Startup 
 BO Client Startup 
 Uninstall OMX SECUR Back Office 
 New BO Client Users 

 

Contents 
 

Procedures: 
 Viewing Startup Progress 
 Setting Security Options 
 Viewing Instance # 
 Logging In 
 Analysing and Reporting Problems 
 Removing an Instance 
 Removing the Watchdog 
 Error! Reference source not found. 
 Adding New Windows 2000 Users  

Tables: 
 Log Files 

Figures: 
 DOS Command Prompt 
 Error! Reference source not found. 

Information: 
 Watchdog Control 
 Client Icons 
 Uninstall Program 

To top of chapter 3. 

3.1 BO Server Startup 

3.1.1 Watchdog Control  

The BO Server is started and restarted automatically by the Watchdog process. The Watchdog is 
restarted when the computer is restarted. The user does not need to perform any actions to run the 
BO Server. 

The first time the server starts, it downloads all active trades, all accounts, yesterday’s information 
and today’s instruments into the database. This may take some time.  

Note:  We strongly recommend that the first startup take place outside trading hours since the 
download can affect the performance of potential trading applications sharing the same 
physical connection.  

3.1.2 Viewing Startup Progress 

The progress of the startup can be followed in the server log file: 

Bo_srv_<INSTANCE>_<NODE>.LOG  
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The log file is located in the Logfiles directory, specified in the Folder dialog. When the startup 
process is complete, the BO Server prints “Init is complete. Doing the main loop.”  

3.1.3 Setting Security Options 

Before taking the OMX SECUR Back Office Application into service, the local security settings in 
Windows on the Server computer must be set to prevent users to use blank passwords in their 
localhost domain.  

Actions for Windows 2000 

1. Log in as Administrator to the computer running the BO Server. 

2. Select Start ⇒ Settings ⇒ Control Panel ⇒ Administrative 
Tools ⇒ Local Security Policy. 
Result:  The Local Security Settings window opens. 

3. Select Account Policies ⇒ Password Policy.  
Result:  A list opens displaying policy items. 

4. Check whether the value for the “Minimum password length” item is set to 0 
(zero). In this case, double-click on “Minimum password length” and set it to 
a value greater than zero ⇒ OK. 

3.1.4 Changing OMnet Server Password 

The OMnet server password is set during the installation. Use this procedure if you like to change it 
after the installation: 

1. Open the folder in which the BO server executable resides. 

2. Start a DOS command prompt window on your machine. 

3. Drag and drop the server executable file onto the DOS prompter window. If the path name 
includes spaces enclose all of it in double quotes: 

4. a) Add a space and the argument –chpassw. 

5. b) Add a space and the instance number of the configuration. 

 

6. Press [Enter]. 

7. Enter new server password and press [Enter]. 

Windows 
2000 
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8. Confirm new password and press [Enter]. 
Result:  The server password is successfully changed. 

 

It’s also possible to enter everything in one row:  

–chpassw <new password> <new password> 

3.2 BO Client Startup 

3.2.1 Client Icons  

As part of the installation, the program group OMX SECUR was added to the Start menu. The 
program name became Back Office for <Application Title>, where <application title> was 
entered during the installation in the Client Settings dialog, see 2.2.6 step 15. Figure 8: shows 
an example. 

Figure 8:  Start Menu Path to the OMX SECUR Back Office Client. 

 

3.2.2 Viewing Instance # 

To figure out to which instance # the application title relates, perform the following steps: 

1. On Windows Start menu, choose Programs ⇒ OMX SECUR ⇒ Back 
Office for <Application Title>. 

2. ⇒ Properties on the right-click menu. 
Result:  The Back Office for <Application Title> Properties 

dialog opens. 

3. ⇒ Shortcut view ⇒ Target field. 
Result:  The Target field shows the instance #. 

 

3.2.3 Logging In 

Use this procedure to log in to the BO Client: 

1. Switch on the PC. 

2. In Windows Login dialog enter your Windows username and password. 
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3. On Windows Start menu, choose Programs ⇒ OMX SECUR ⇒ Back 
Office for <Application Title>. 
Result:  The OMX SECUR splash screen is presented Figure 3: followed by 

the OMX SECUR Login dialog. 

 

4. In OMX SECUR Login dialog enter your Windows Username and 
Password. 

⇒ OK 

Note:  The BO Client uses Windows Username and Password. 

 Result:  If the login was successful, the OMX SECUR B/O main menu 
appears, see Figure 2: . 

 

3.2.4 Exiting 

To exit the BO Client, choose File ⇒ Exit. 

3.2.5 Analysing and Reporting Problems 

Information about application problems is stored in the process log files located in: 

<ROOT>\LogFiles. 

Table 9:  Log Files 

Process Log File Name 

BO Server Bo_srv_<INSTANCE>_<NODE>.LOG 

BO Client Bo_client_<VERSION>_<INSTANCE>_<NODE>.LOG 

BO Watchdog Bo_wtchdg<NODE>.LOG 
 

When reporting problems of any kind to OMX SECUR personnel, please send the contents of the 
log files directory in the problem report. When reporting improvement suggestions, this is not 
necessary. 

To top of chapter 3. 
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3.3 Uninstall OMX SECUR Back Office 

3.3.1 Uninstall Program 

An instance of OMX SECUR Back Office Server or Client can be removed automatically by using 
the Uninstall Back Office program. 

Figure 9:  Start Menu Path to the OMX SECUR Uninstall Back Office 

 

The Uninstall program removes the selected instance of the OMX SECUR Back Office, 
including: 
• All files belonging to this instance but only if no other instance shares the file 
• The service for this instance of BO Server for a server installation 
• The ODBC connection for a server installation 
• All log files in the Logfiles directory created by the server and client for this instance. 
• All interface files belonging to this instance 
• All registry entries for this instance in: 

HKEY_LOCAL_MACHINE\SOFTWARE\OM\OMX SECUR\BackOffice\<INSTANCE> 

Note:  To remove all instances of the Back Office first remove the Watchdog manually as 
described in 3.3.3. 

3.3.2 Removing an Instance 

Use this procedure to remove an instance of the BO Application: 

1. Switch on the PC. 

2. In Windows Login dialog enter Windows username and password. 

3. On the Windows Start menu, choose Programs ⇒ OMX SECUR ⇒ 
Uninstall Back Office for <Application Title>. 
Result:  The OMX SECUR Back Office instance is removed as described 

above. 
 

To top of chapter 3. 
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3.3.3 Removing the Watchdog 

When removing an instance of BO Server or Client the Watchdog will remain. When removing all 
instances the Watchdog must be be removed manually by using the DOS Command Prompt. 

Figure 10:  DOS Command Prompt 

 

To remove the BO Watchdog service use the following procedure: 

1. Open the program folder <ROOT>\BinaryFiles. 

2. Choose the DOS Command Prompt window. 
Result:  The DOS Command Prompt window opens Figure 10: . 

3. Drag and drop the BO Watchdog executable file into the DOS Command 
Prompt window. If the path includes spaces enclose all of it in double 
quotes. 

4. Add a space and the argument –remove. 

5. Press [Enter]. 
Result:  The BO Watchdog service is removed. 

 

To top of chapter 3. 

3.4 New BO Client Users 
Since the BO Client uses Windows authentication, adding a new BO Client user is the same as 
adding a new Windows user. 
 

To top of chapter 3. 

 

3.4.1 Adding New Windows 2000 Users 

Use the following procedure to add new Windows 2000 users on the localhost: 

1. Choose Start ⇒ Settings ⇒ Control Panel, double-click the 
Administrative Tools icon and then the Computer Management 
icon. 
Result:  The Computer Management window opens. 

Windows 
2000 
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2. In the tree choose Local Users and Groups and double-click the Users 
folder.  
Result:  The users are displayed. 

3. Select empty space in the list ⇒ New User on the right-click menu. 
Result:  The New User dialog opens. 
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4. Specify User name, Full name, Description (optional), Password 
and Confirmm password ⇒ Create ⇒ Close. 
Result:  A new user has been added. 

 

To top of chapter 3. 
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